Go Back   Forums > Abandonia.com > Troubleshooting
Memberlist Forum Rules Search Today's Posts Mark Forums Read
Search Forums:
Click here to use Advanced Search

Reply
 
Thread Tools Display Modes
Old 12-01-2005, 10:07 AM   #1
Ionize
Newbie

 
Join Date: Jan 2005
Location: ,
Posts: 10
Default

Hey all, First off great site and damn nice selection. It brings me back to the gold old days heehee

But on a more serious note, with my system which is a 1.8ghz p4 with 512mb ram dosbox runs beautifully .............. that is when it decides to run. Whenever I mount my games folder and try to run a game ( Another World - Specifically! ) it gives me a message:

A memory manager has been detected and may impare performance......consult your dos manual etc.

Now as far as i know I have no 3rd party memory managers and if xp sp2 has one then how can i disable it. Its just really annoying as the game may work from time to time but seems to crash when entering the code wheel codes.

Thanks
Ionize
Ionize is offline                         Send a private message to Ionize
Reply With Quote
Old 12-01-2005, 10:14 AM   #2
mouse31e
Games Master

 
Join Date: Oct 2004
Location: Aylesbury, England
Posts: 335
Default

Find these lines in your DOSBox Config file and make sure they read like this:

xms=true
ems=false

Then run the game - should be fine, I just tested it and it got rid of the error message!

Hope that helps!
mouse31e is offline                         Send a private message to mouse31e
Reply With Quote
Old 12-01-2005, 10:15 AM   #3
Eagle of Fire
Friendly Fire
 
Eagle of Fire's Avatar

 
Join Date: Sep 2004
Location: Valleyfield, Canada
Posts: 4,892
Default

It might be because the game doesn't allow EMS and/or XMS (the latter would be surprising).

Go into the configuration file of your DOSBox version (Dosbox.conf, open it with notepad it's in fact a .txt file in disguise) and scroll down until you encounter those lines, by the end of the file:
Quote:
[dos]
# xms -- Enable XMS support.
# ems -- Enable EMS support.

xms=true
ems=true
Try changing "ems=true" to "ems=false" and try again. If it still doesn't work, then try the same with xms.

Do not forget to change this back if you wish to play other games with DOSBox.

Hope this help. k:

Edit: Rats, the Mouse beat me to it. LOL
__________________
I'm on a hot streak... Literally.
Proud member of The Abandoned since 2005.
Eagle of Fire is offline                         Send a private message to Eagle of Fire
Reply With Quote
Old 12-01-2005, 10:28 AM   #4
Data
retired
 
Data's Avatar


 
Join Date: Jun 2004
Location: Jan Mayen, Svalbard and Jan Mayen
Posts: 2,167
Default

some games need both to be set to false (like zone66)
__________________
Flowing with the stream of life
Data is offline                         Send a private message to Data
Reply With Quote
Old 12-01-2005, 10:54 AM   #5
Ionize
Newbie

 
Join Date: Jan 2005
Location: ,
Posts: 10
Default

Thanks a lot folks. Thats perfect :Brain:
Ionize is offline                         Send a private message to Ionize
Reply With Quote
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
Memory Problems with M&M IV-V. fetherin Troubleshooting 2 04-05-2009 01:56 AM
Ems Memory Manager stides Troubleshooting 3 11-06-2007 02:25 PM
Dos Memory Problems Under Win98se Mighty Midget Tech Corner 16 31-07-2006 07:33 PM
Usb Memory Stick Problems. Bobbin Threadbare Tech Corner 4 27-01-2006 12:56 PM
Extended Memory Manager In Dosbox `? swiss Troubleshooting 2 02-11-2005 10:16 PM

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Forum Jump
 


The current time is 07:24 PM (GMT)

 
Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.