Go Back   Forums > Abandonia.com > Troubleshooting
Memberlist Forum Rules Search Today's Posts Mark Forums Read
Search Forums:
Click here to use Advanced Search

Reply
 
Thread Tools Display Modes
Old 28-08-2006, 03:52 AM   #1
hgottfried
Newbie

 
Join Date: Aug 2006
Location: ,
Posts: 5
Default

I am playing Magic Carpet (#1) in dosbox. I own the original cdrom, which is in drive d:
this is what the tail end of my dosbox.conf file looks like:
[autoexec]
# Lines in this section will be run at startup.
mount C C:\DOS\CDrive
mount D D:\ -t cdrom
C:


I assume that the game is not finding the cdrom, but i can't make heads or tales of the readme file--I don't mean to waste anyone's time with a stupid question, but is there an easy line or two I can add to my config file to fix this, and exactly what should that line look like (i assume it would be a modified "mount D" line)? I can play the game for a minute or two at a time before I get kicked back to dos (d: prompt). Everything else seems to be working great! Thanks for any help out there.

oh, and i'm running windows xp home with sp2.
hgottfried is offline                         Send a private message to hgottfried
Reply With Quote
Old 28-08-2006, 07:43 AM   #2
Data
retired
 
Data's Avatar


 
Join Date: Jun 2004
Location: Jan Mayen, Svalbard and Jan Mayen
Posts: 2,167
Default

try chaning your second line:
mount d d:\ -t cdrom -ioctl -usecd 0
__________________
Flowing with the stream of life
Data is offline                         Send a private message to Data
Reply With Quote
Old 28-08-2006, 02:49 PM   #3
The Fifth Horseman
FUTURE SCIENCE BASTARD
 
The Fifth Horseman's Avatar


 
Join Date: Oct 2004
Location: Opole, Poland
Posts: 14,264
Default

What with sound? Are you sure that the game is configured to use the same soundcard, input, DMA and IRQ that are configured in DosBox?
IRQ differences are particularly devious, as the sound can run semi-normally before a crash happens.
__________________

"God. Can't you people see I'm trying to commit a crime against science and nature here?"
-- Reed Richards
The Fifth Horseman is offline                         Send a private message to The Fifth Horseman
Reply With Quote
Old 29-08-2006, 05:40 AM   #4
hgottfried
Newbie

 
Join Date: Aug 2006
Location: ,
Posts: 5
Default

QUOTE(Data @ Aug 28 2006, 12:43 AM) [snapback]251355[/snapback]
Quote:
try chaning your second line:
mount d d:\ -t cdrom -ioctl -usecd 0
[/b]
tried that. still got the same results. thanks for trying to help, though; i really appreciate it.

QUOTE(the_fifth_horseman @ Aug 28 2006, 07:49 AM) [snapback]251452[/snapback]
Quote:
What with sound? Are you sure that the game is configured to use the same soundcard, input, DMA and IRQ that are configured in DosBox?
IRQ differences are particularly devious, as the sound can run semi-normally before a crash happens.
[/b]
i made sure the settings in the game sound setup were the same as the dosbox defaults, but i still got the same crash. tried different combos of various soundblaster and adlib choices, but still can't get it to work. thanks for trying, though; i appreciate it.
hgottfried is offline                         Send a private message to hgottfried
Reply With Quote
Old 29-08-2006, 09:02 AM   #5
Scatty
Treasure hunter
 
Scatty's Avatar

 
Join Date: Jan 2006
Location: Little big small world
Posts: 1,875
Default

Read these comments, maybe they'll help you - DosBox site
Scatty is offline                         Send a private message to Scatty
Reply With Quote
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
The Horde heatho On site 7 14-07-2009 11:48 AM
Magic Carpet 2 Kreepah Troubleshooting 1 08-01-2006 08:28 AM
Magic Carpet 2 : The Netherworlds Kreepah Troubleshooting 2 14-07-2005 06:07 AM
Magic Carpet 2 Kreepah Troubleshooting 1 26-05-2005 01:35 PM
Magic Carpet 2 Help Guest_kreepah Troubleshooting 0 28-12-2004 10:06 AM

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Forum Jump
 


The current time is 09:55 AM (GMT)

 
Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.