Go Back   Forums > Abandonia.com > Troubleshooting
Memberlist Forum Rules Search Today's Posts Mark Forums Read
Search Forums:
Click here to use Advanced Search

Reply
 
Thread Tools Display Modes
Old 31-01-2011, 09:00 AM   #1
wackypanda
Abandonia nerd

 
Join Date: Jan 2011
Location: ,
Posts: 51
Default Admiral Sea Battles cannot run

Does anybody remember this game? It was a turn-based strategy game involving fleets of ships, forts, and movement was tile-based.

Anyway, I'm on a mission to get it to work. (I'm working with a demo, so even if it's not considered abandonware please bear with me.) I've never been able to get it working on anything other than a physical Windows 98 (first edition) or physical Windows ME. Unfortunately the only working parts I have of those are the contents of the CPU towers, and those haven't been used in a long time so I don't know if they still work.

I've tried to run it on a Windows ME installed in VMware Player with VMware Tools installed. This brings up "Could not find Wing32.dll". After installing the WinG package from this site, Admiral does absolutely nothing when executed. If it even gets as far as attempting to change the resolution, I can't tell.

I hope I'm not being too vague. Any thoughts?
wackypanda is offline                         Send a private message to wackypanda
Reply With Quote
Old 31-01-2011, 09:19 AM   #2
dosraider
Dismembered.
 
dosraider's Avatar

 
Join Date: Aug 2007
Location: Dixmuide, Belgium
Posts: 2,767
Default

First thought, VPC is still the best bet for W98/ME.
But if installed correctly W98/ME *should* work in VmWare.
Second thought: for gaming in a virtual machine you're really better with W98(SE)

Next, is there a 'readme' file with the game? If yes, read it.
Most likely problems:
-desktop res/color settings
-game not installed correctly
-wrong WinG version (should be on the install disks)

And that's it, without the game can't tell you more, nor do some testruns.
__________________

Not a member of The Victorious People's Shoutbox Liberation Army.
Not a member of the GAG Guerrilla. Don't get A Grip!
FOR RENT
*Advertising space*
dosraider is offline                         Send a private message to dosraider
Reply With Quote
Old 31-01-2011, 03:40 PM   #3
The Fifth Horseman
FUTURE SCIENCE BASTARD
 
The Fifth Horseman's Avatar


 
Join Date: Oct 2004
Location: Opole, Poland
Posts: 14,264
Default

If it's relying on WinG, Windows 3 or Windows 95 is your best bet. And yes, it should work in a virtual machine.
__________________

"God. Can't you people see I'm trying to commit a crime against science and nature here?"
-- Reed Richards
The Fifth Horseman is offline                         Send a private message to The Fifth Horseman
Reply With Quote
Old 01-02-2011, 03:59 AM   #4
wackypanda
Abandonia nerd

 
Join Date: Jan 2011
Location: ,
Posts: 51
Default

I chose Windows ME because I played most of my old games on the physical Windows ME before I lost the hardware to go with the tower. But now I'm going with 98.

Installation seems the most likely, since according to the readme it should install WinG on its own, so I'll have to dig up my stuff and try that again. Thanks.
wackypanda is offline                         Send a private message to wackypanda
Reply With Quote
Old 27-10-2018, 09:49 AM   #5
Eporedorix47
Lurker

 
Join Date: Oct 2018
Posts: 1
Default

Quote:
Originally Posted by wackypanda View Post
Does anybody remember this game? It was a turn-based strategy game involving fleets of ships, forts, and movement was tile-based.
...
I hope I'm not being too vague. Any thoughts?
Hi, I remember this game even if I only played demo in 1996 like 8y old kid. Around month ago I had download it and install Windows 98SE on virtualbox. Installation went smooth but I had to install win installer 2.0. But graphics were terrible with no audio.
After one hour of trying various drivers I have installed DisplayDoctor 7 and register it with registration code found as a first search on google. After that you should be able to go with nice graphics even over 256colour.
Default virtual audio card need to be changed as there is no driver to support MIDI sound format which is Admiral using. If you will search for "MIDI w98se on virtualbox" you will get into right solution with win95 audio driver which needs to be unzipped and with right files you can install it on w98se.
Sorry for not very exact solution but I dont remember it very well as I did it during 2hours in work and I am on different machine with not much time now.
At the end you should be able to play the game smoothly with nice video/audio. The only thing which is not working fine is cursor which is blinking and this is making aiming harder but not a big deal anyway.
Eporedorix47 is offline                         Send a private message to Eporedorix47
Reply With Quote
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost Admiral, The ReamusLQ Games Discussion 6 17-09-2014 10:14 PM
Space Battles Paco Approved Requests 1 02-02-2010 02:55 PM
Battles of Napoleon LaFey Approved Requests 4 22-09-2009 03:35 PM
Admiral - Sea Battles turcotte Approved Requests 14 02-09-2009 06:46 PM
Battles on distant Planets pandagopanda Approved Requests 1 08-08-2007 05:21 PM

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Forum Jump
 


The current time is 10:30 PM (GMT)

 
Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.