Go Back   Forums > Community Chatterbox > Tech Corner
Memberlist Forum Rules Search Today's Posts Mark Forums Read
Search Forums:
Click here to use Advanced Search

Reply
 
Thread Tools Display Modes
Old 28-07-2005, 06:09 PM   #1
efthimios
Home Sweet Abandonia

 
Join Date: Apr 2005
Location: ,
Posts: 957
Default

Getting upset with Opera 8+ recently, having tried Firefox and getting more crashes that with IE (no kidding), plus not working properly at times, I was on the look for a new browser. Downloaded Netscape 8.02 last week and it worked. Very nice one. So yesterday I updated to 8.03 and now most of the download links on sites do not work...
I will wait and see if they fix this quickly.

Anyhow, any OTHER suggestions for a browser under windows XP?
Please do not suggest any that are others in camouflage (sp?) like Avant which is a nice one but it is IE.

efthimios is offline                         Send a private message to efthimios
Reply With Quote
Old 28-07-2005, 06:41 PM   #2
Rogue
10 GOSUB Abandonia
20 GOTO 10
 
Rogue's Avatar

 
Join Date: Nov 2004
Location: Afrim, Albania
Posts: 2,113
Default

Are you sure that you have problem with browser???

Firefox works fine for me, and I have installed all other major browsers as well (to test web design), older versions, but no problems with any of them, including IE!

What version and what kind of problems did you have with Firefox, and what skins/plugins did you have installed?

Also what version of Java do you have?
Rogue is offline                         Send a private message to Rogue
Reply With Quote
Old 28-07-2005, 06:54 PM   #3
MdaG
Abandonia Homie

 
Join Date: Mar 2005
Location: ,
Posts: 545
Send a message via ICQ to MdaG Send a message via AIM to MdaG Send a message via MSN to MdaG Send a message via Yahoo to MdaG
Default

If I get weird "bugs" in Windows that I can't fix I usually swipe the partition and reinstall. That has worked 3 out of 3 times.

*edit*

I'm using Firefox 1.06 and I have no problems whatsoever.
__________________
-=Firthy2002=-
------------------
My LiveJournal
MdaG is offline                         Send a private message to MdaG
Reply With Quote
Old 28-07-2005, 08:05 PM   #4
Eagle of Fire
Friendly Fire
 
Eagle of Fire's Avatar

 
Join Date: Sep 2004
Location: Valleyfield, Canada
Posts: 4,892
Default

I find firefox buggy as well.

I didn't install any plugin or skins, which are unnecessary.

I also don't have java installed.
__________________
I'm on a hot streak... Literally.
Proud member of The Abandoned since 2005.
Eagle of Fire is offline                         Send a private message to Eagle of Fire
Reply With Quote
Old 28-07-2005, 08:26 PM   #5
swiss
who's not Swiss
 
swiss's Avatar

 
Join Date: Jun 2005
Location: Velen, Germany
Posts: 711
Default

but you are running your windows XP with the latest Service Packs ? Maybe you have some Firewall or Security options that makes your download not work ...


I have Firefox 1.04 and never ever had a problem.

Having a wrecked system make no 3rd party Software being ultra-stable ...

swiss is offline                         Send a private message to swiss
Reply With Quote
Old 28-07-2005, 08:53 PM   #6
Koen
Game Wizzard
 
Koen's Avatar

 
Join Date: Nov 2004
Location: Nootdorp, Netherlands
Posts: 226
Default

Firefox (as do other apps) seems to hang when 'hyperthreading' is on in my bios. When I turn it off, i have no problems.
Koen is offline                         Send a private message to Koen
Reply With Quote
Old 28-07-2005, 09:45 PM   #7
Danny252
I have a custom title!

 
Join Date: Oct 2003
Location: Telford, England
Posts: 1,303
Default

hyperthreading does wierd stuff to loads of things, so I hear...
__________________
I liked the old forum.. =/
Danny252 is offline                         Send a private message to Danny252
Reply With Quote
Old 28-07-2005, 10:02 PM   #8
punch999
The true Shadow President
 
punch999's Avatar

 
Join Date: Sep 2004
Location: Celebration, United States
Posts: 1,195
Default

mozzilla works perfectly well for me. :blink:
punch999 is offline                         Send a private message to punch999
Reply With Quote
Old 29-07-2005, 12:33 AM   #9
efthimios
Home Sweet Abandonia

 
Join Date: Apr 2005
Location: ,
Posts: 957
Default

OK, let me answer each one of you. :-)

Firefox apart from the occasional remaining of ghost image (that eats very real memory) it also does not care if I want a new link to open in a new tab, no matter what option I have on/off. Unless I right click on the link and choose open in new tab it refuses to do so.
Plus it crashes one time every couple of days.
It is version 1.0.4
Extensions I have are Flashblock, Play Launch, PopupSound, Basics, Copy All Urls, Duplicate Tab, HashColouredTabs, Magpie, QuickTabPrefToggle, SessionSave.2, Super DragAndGo, Tab X, BetterSearch.
All of them lovely but irrelevant to the problems since the problems existed BEFORE I installed any of them.

I have Java 2 Standard Edition 1.4.2_04 with Defualt Virtual Machine Version 1.4.2_04-b05 and plug in 1.4.2_04 I doubt this has anything to do with the problems.


MdaG, re installing windows is a no no for me, the system works amazingly well, though I am sure it will not survive the year. I also have everything ever wanted installed and the GUI and other settings in perfect harmony, I am not going to erase them because of buggy browser software. I agree I used to do the same but apart from that windows work flawlessly, at times I leave it on for days and days without problems.

swiss, I do not have SP2 installed. I have SP1 with all SP2 that were allowed to be installed without installing the SP2 from windows update. I will NOT install SP2 even if I need to re install windows some day. I have a back up idea for that case.

Firewall and antivirus I think are not very relevant to the exact problems facing this time. All in all I am very happy with the ones I use.
I am also very careful about what programs I install so I do not think that that has anything to do with it this time.

I am not sure that my cpu has hyperthreading. It is a Pentium M 4 @1.7 edition oh 2002.

I haven't tried Mozilla for some time now (even before the Firefox got its name) but I do not think I want to go back to that.

The problem I mentioned with Netscape 8.03 is a known bug since others are having it too.
Opera is have some serious memory management problems with version 8+ mainly leaks. I don't know if they will fix them but I hope so.

Thanks for trying to help guys.

My guess is then that none of you use any other browser?
efthimios is offline                         Send a private message to efthimios
Reply With Quote
Old 29-07-2005, 01:37 AM   #10
omg
Games Master

 
Join Date: Apr 2005
Location: ,
Posts: 303
Default

LOL have you tried lynx?
omg is offline                         Send a private message to omg
Reply With Quote
Reply


Similar Threads
Thread Thread Starter Forum Replies Last Post
Creation Of Browser Based Games gufu1992 Blah, blah, blah... 9 19-02-2010 01:02 PM
Anyone Tried The New Safari Browser? Sebatianos Tech Corner 2 04-09-2007 07:50 AM
The Abandonia Web Browser chickenman Programming 72 26-03-2006 05:08 PM
Web Browser John Watts Blah, blah, blah... 41 16-02-2005 01:39 PM
Browser Wars Tulac Blah, blah, blah... 28 02-01-2005 03:51 PM

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump
 


The current time is 10:42 PM (GMT)

 
Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.