View Single Post
Old 24-01-2011, 12:57 AM   #2
Japo
Autonomous human
 
Japo's Avatar


 
Join Date: Mar 2006
Location: Valladolid, Spain
Posts: 4,385
Default

No idea why DOSBox should fall back to windowed mode... O_O

You did right with fullresolution, but you also need to change "scaler": anything but the default "surface" value will fix your problem, pick "overlay". Also change "aspect" to "true".

Quote:
Originally Posted by Japo View Post
One last tip. When playing in full screen we may see an empty black frame surrounding the game image, which in addition may not be centered. I recommend the following changes to the default configuration. Open it by going to the Windows start menu > DOSBox-x.xx > Options > DOSBox-x.xx Options. You will see a text file, look for "aspect=" and change the rest of the line to "true":


Look also for "output=" and set it to "overlay", and "fullresolution=" to the maximum, native resolution of your monitor (in my case for example, "1920x1080"). Make sure to save the changes and close the notepad.

(If you have a 4:3 monitor the image should fill the whole of it, but if you have a wide screen you'll get black stripes left and right. Don't worry, there's nothing wrong about it, otherwise the image would be distorted; if you wish to learn more, read about "fullresolution" in the configuration file tutorial. However you should never see black space at the top and bottom.)
(I think a FAQ sticky would be a good idea, in addition to the tutorials...)
__________________
Life starts every day anew. Prospects not so good.
Japo is offline                         Send a private message to Japo
Reply With Quote