View Single Post
Old 30-05-2009, 04:03 PM   #9
Simoneer
Priest of The Order
 
Simoneer's Avatar


 
Join Date: Mar 2009
Location: Sundsvall, Sweden
Posts: 406
Default

Quote:
Originally Posted by dosraider View Post
Something to do with....
Well, I had the same crap with 0.72 (but only after I reinstalled the PC!). I must seriously have messed something up. Although, I now have the proper conf in there... and same crap still.

Quote:
Originally Posted by The Fifth Horseman View Post
Simoneer:
aspect=false in DOSBox.conf . Change to aspect=true . This should help.
If it doesn't, what is your display's aspect ratio (or just the resolution, comes down to the same thing)?
That worked.

1280 x 1024, btw.


Quote:
Originally Posted by Japo View Post
Edit the .conf file and replace "fullresolution=original" with another resolution that matches the physical aspect ratio of your screen. To see what choices you have, right-click on the Windows desktop and access the dialogue where you can change the resolution. To know the aspect ratio of each choice, just divide both dimensions with a calculator. To know the physical aspect ratio of your screen, get some tape measure and divide both dimensions in centimeters or inches or whatever.

Still, you may get the same "problem" that the images from DOS games don't cover the whole screen, because each game has its own aspect ratio. 320x200 and 640x400 have 1.6 (16:10) and 640x480 1.33 (4:3).

You can get the the image from DOSBox to fill the whole screen by enabling "aspect=true" in the .conf file. But there is hardly any point in using that option: the anti-aliasing will blur the image, and there's no advantage in enlarging an image across one of the two dimensions by stretching the pixels.
Hmm... Yeah, I suppose I should play around with it a bit. Although I've done so alot already (and it seems to either get widescreen'd, or just... extremely small).

Quote:
Originally Posted by dosraider View Post
It works. If you put a dosbox.conf in your dosbox-0.73 folder it will use that one.
But there is no real reason to do that.
The default one is stored as
\AppData\Local\DOSBox\dosbox\dosbox-0.73.conf

If no dosbox.conf is present in the dosbox-0.73 folder it will use the default one.
If a dosbox.conf file is present in \program files\dosbox-0.73\ it will use that one, not the default one.

Of course you can add all that you want under [autoexec] in the default one.
So there is no real reason to want one in your dosbox-0.73 folder, except if you want to create several game specific config files.

Notice:
In the \appdata\blahblah\ it's named dosbox-0.73.conf
In the \program files\dosbox-0.73\ folder it must be named dosbox.conf
to be loaded at startup.
Game specific ones loaded in the specific game shortcut can be named whatever.conf


And Simoneer: it's still a screwed idea to put your old 0.72 dosbox.conf file in 0.73.
Yes. Thank you for the help... I had NO idea where that conf file was.

I don't have much understanding of this stuff. I just went with the only thing I could think of. >.>


Thank you all for taking the time.
__________________
---last.fm
Simoneer is offline                         Send a private message to Simoneer
Reply With Quote