Forums

Forums (http://www.abandonia.com/vbullet/index.php)
-   Troubleshooting (http://www.abandonia.com/vbullet/forumdisplay.php?f=11)
-   -   Gobliiins & Gobliins 2 CD versions won't work for me (http://www.abandonia.com/vbullet/showthread.php?t=528)

Anonymous 30-07-2004 11:00 PM

Gobliiins & Gobliins 2 CD versions won't work for me
 
I just found the "Sierra Classics" CD versions of the first two Goblins games at the back of my cupboard. WOO HOO! :D

I've been trying to get them to work in Windows XP but have had no luck.

Gobliiins starts up fine, the opening "movie" works okay, but the game itself re-defines the word "choppy" (Instead of 80 frames per second, I'm getting about 1 frame every two seconds!)

Gobliins 2 on the other hand won't even start-up. It just hangs with a black screen. (The CD isn't even being acessed)

I've downloaded Goblins 3 from this site (great site, BTW) and it works fine (maybe because it doesn't include CD music, speech, etc.)

I've tried running these games with VDMSound, but there's no difference.
In Win95 Compatibility mode there's also no change.
And in DosBOX the CD doesn't seem to be recognised (even though I've mounted it on drive D).

I was hoping someone here had an idea, an inkling, or even an inspiration as to how I can run these CD versions.

FreeFreddy 31-07-2004 08:20 AM

Yes, I noticed too, that mountig CD-drive with DosBox doesn't bring any results, the CD-drive is still not recognizeable from the games that need that.
Well, what I could propose is a little hard at first, but working almost without problems later solution - use Windows 98 on second partition of your harddrive.
Where DosBox fails, Windows 98 still does it. If you need detailed info on how to split your harddrive, than install Windows 98 and after that Windows XP, just PM me, I'll PM you the info then.

Data 01-08-2004 11:51 AM

did you try mounting the cdrom in dosbox with the correct flags ?

examples. basic cdrom support

mount d d:\ -t cdrom

sdl support:
mount d d:\ -t cdrom -usecd 0

ioctl support:
mount d d:\ -t cdrom -usecd 0 -ioctl

or win98 aspi:
mount d d:\ -t cdrom -usecd 0 -aspi

change the number 0 in -usecd 0 to the correct number shown by :
mount -cd

Tom Henrik 01-08-2004 12:07 PM

:shock:

Anyone out there who still wonders why Data has that signature of his?!

Niiiiiiiiiiiiiiice :D

Malchior 03-08-2004 06:10 AM

Damn, looks like I wasn't logged in when I posted that first message.

Anyway, thanks heaps Data. I wasn't mounting my CD-ROM correctly. Gobliins 2 now plays, however the game is very slow like Gobliiins. I did check out DosBOX's compatibility page and I see they state the same problem, so I guess I'll have to wait for an updated version.


In the mean time, I've been playing the version offered on this site and i've been having a ball!


The current time is 10:17 AM (GMT)

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.