Forums

Forums (http://www.abandonia.com/vbullet/index.php)
-   Tech Corner (http://www.abandonia.com/vbullet/forumdisplay.php?f=23)
-   -   Need help with Tandy CoCo emulation (http://www.abandonia.com/vbullet/showthread.php?t=46178)

Neville 10-08-2018 04:28 PM

Need help with Tandy CoCo emulation
 
So I've been trying to get xRoar running, following this Youtube guide, because I've never owned nor used a real CoCo:

https://www.youtube.com/watch?v=YGa8LgHcW_Y

While it's been very helpful, I've encountered issues while trying to run stuff like the Sierra games. I insert the first disk, type DOS (or use the CTRL+MAYS+L shortcut) and then the screen goes like this:

https://i.imgur.com/Vf9q4SW.jpg

In theory, these games should work with Extended Basic 1.1, and I can't figure out what I'm doing wrong. It doesn't help that these games often come in several different versions, such as DrivePak or DriveWire. Are those copier programs for the CoCo?

Smiling Spectre 10-08-2018 11:05 PM

Sounds vaguely familiar. I seen similar theme in Total Dos Collection forums. As I (vaguely) remember, trick is that you need Basic that was embedded in ROM - so you need to connect this ROM somehow. I could find the branch, probably, but I felt like it was special DOSBox build, not this XRoar. Maybe it have some options somewhere?

Neville 11-08-2018 11:19 AM

I'll try with a different ROM, thank you. Although I think the problem might be these Sierra games are for CoCo 3 and xRoar only emulates CoCo - CoCo 2. I might need a different emulator for these games.

Neville 11-08-2018 12:49 PM

OK, definitely using the wrong emu was part of the problem. I've switched to VCC and tried to boot (using the instruction DOS) several Sierra games.

In the best of cases, this is the result:

https://i.imgur.com/uVBuglO.jpg

The ROMs seem built-in the emulator, so I'm not using any external BIOS. Any ideas?

Smiling Spectre 11-08-2018 10:01 PM

Aww. Checked discussion. It was PC Jr actually. Sorry.

Anyway, I checked Some wiki, and found that your error means "File not found" - and it means that "11" (that is first command in your screenshot) either is not recognizable file, or path for it is different.

Neville 01-11-2021 11:26 AM

I finally solved the issue. It only took me years!

So if you still want to play Sierra CoCo3 games, follow these steps:

1) Use VCC and the dumps of the original disks. Newer versions won't do.

2) Load the disks with the instruction DOS, then you will be prompted for the date and time of the system. Use the same syntax as you're given.

https://i.imgur.com/wbTaFV3.png

3) Then, load the games with the SIERRA command.

Now you can enjoy said games. Thanks to those online kindred souls that helped or tried to.

https://i.imgur.com/vurAHfp.png

DrWho42 10-12-2021 12:23 AM

whoa! glad it's solved <3


The current time is 01:53 PM (GMT)

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.