Go Back   Forums > Abandonia.com > Games Discussion > Civilization 2
Memberlist Forum Rules Search Today's Posts Mark Forums Read
Search Forums:
Click here to use Advanced Search

Thread: Civilization 2 Reply to Thread
Your Username: Click here to log in
Image Verification
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Additional Options
Miscellaneous Options

Topic Review (Newest First)
26-06-2018 12:13 PM
Rogue Civ 2 buy link does not work anymore. Civ 2 and Civ 1 are not available on Steam or GOG.com.
11-12-2010 06:25 PM
The Fifth Horseman Boot Camp or WINE.
11-12-2010 05:30 PM
JBaillie
Mac Version ??

CIV II is my favorite game of all time. I currently have an Apple running OS 10. So my old CD doesn't run. Any ideas?
18-03-2010 04:39 PM
Paco
Quote:
Originally Posted by Dragom View Post
Manual doesn't work... corrupted?
Download and unzipping works. opening PDF-File works. try to download it again.
18-03-2010 04:33 PM
Dragom
Quote:
Originally Posted by Kosta View Post
Feel free to comment and discuss this game here. Also, if you have any useful tips or tricks don't hesitate to share them with the others! Thanks!

Review and download (if available)

Manual doesn't work... corrupted?
12-10-2009 07:29 PM
justkc Too bad it's protected. I'd like to vote that Civ 2 might be the best in the franchise, excluding Alpha Centauri.

If you can find a copy, it's worth it. Unless you're into graphics. In which case, maybe you're at the wrong website.
06-07-2009 09:36 AM
The Fifth Horseman You read the goddamn FAQ before asking questions like that.
06-07-2009 09:23 AM
coco13
Quote:
Originally Posted by lacura11 View Post
how do i download it?
yeah ! how do you download the game...??? or do you play it online...? and HOW?
11-04-2009 12:10 AM
tiagofm
No Sound when I load a Game

Hello!,

I'm running Civilization II in Windows XP. Everything works great, BUT when i Load a previously saved game, i have no Sound.

I tried turning off and on again, saving with no sound and turning it on after loading. Nothing works. No "small musics", unit moves, nothing.

When I select Retire / Quit Game and get back to the start menu of the game, I have sound. And it all works well if I Start a New Game...

Any guesses...? Thanks!
Tiago
20-11-2008 11:37 PM
Luchsen
Quote:
Originally Posted by the FAQ
If instead of on the game page, you see this icon:

It means that this game is either still sold or actively protected by copyright holder or an anti-piracy organisation the copyright holder is a member of (such as ESA).
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may not post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

The current time is 05:16 AM (GMT)

 
Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.